V70 -10 AFV Startar ej på gas

Skriv svar
kklasen
Inlägg: 4
Blev medlem: 2015-04-06, 23:40
Ort: Norrköping

V70 -10 AFV Startar ej på gas

Inlägg av kklasen » 2015-04-07, 00:10

Hejsan.

Söker nu efter hjälp, efter att jag (dum som jag var) råkat tanka E85.
Det började med att motorlampan började lysa. Så jag kollade och fick koden P2177 (Too Lean Off Idle).
Motorn gick hur bra som helst, både på E85 och Gas.

2 Dagar senare skulle jag starta bilen tidigt på morgonen. Det var ovanligt kallt ute.
Den startade inte alls. Körde ca 5 minuter med startförsök om och om igen. Tillslut startade den.
Märkte ingen annan förändring när bilen väl startat. Gick hur bra som helst. Dock hade gasen slutat funka.

Jag körde slut på E85 och tankade vanlig bensin så fort jag kunde när jag märkte detta.

När jag trycker på knappen för gas, så piper det 2 gånger (som vanligt) och inget mer händer. Den visar inte nivå alls.
Så jag testar att hålla inne knappen medans jag startar bilen... Bilen startar och går i ca 3 sekunder och sedan dör.
Försöker jag starta bilen igen, så startar den inte alls tills jag stänger av tändningen helt och på igen.

Jag har kollat alla säkringar jag har hittat i bilen. Alla är hela. Dvs. spänning på både sidor av säkring vid tändning på.
Nu när jag tänker efter, så har jag inte kollat säkringarna under handskfacket.

Men om någon har någon annan idé på varför bilen inte går att köra på gas, skriv en rad så länge. Så kollar jag de andra säkringarna inom kort.
Senast redigerad av 1 kklasen, redigerad totalt 2015 gånger.

kklasen
Inlägg: 4
Blev medlem: 2015-04-06, 23:40
Ort: Norrköping

Re: V70 -10 Startar ej på gas

Inlägg av kklasen » 2015-04-07, 19:48

Har kollat alla säkringar nu. Alla är hela. Om det inte döljer sig något speciellt för gasen på något ställe.

De ställen jag kollat är alltså. Motorutrymmet, under handskfacket och till vänster i bagaget.

Är det CEM eller någon annan dator i bilen som behöver programmeras om?

kklasen
Inlägg: 4
Blev medlem: 2015-04-06, 23:40
Ort: Norrköping

Re: V70 -10 AFV Startar ej på gas

Inlägg av kklasen » 2015-05-06, 23:06

Status inte förändrat. Har kollat tankarna (bilder på det inom kort för er som är intresserade). De går ut år 2030. Det är alltså 20 års livslängd på dessa.

Ska glida in på Rejmes inom kort så får de kolla felkoder med Vida/Dice. Om ingen här är i Norrköpingstrakten med en dice?

I övrigt verkar inte ventilerna öppnas alls. Regulatorn visar numera 0 oavsett vad.
Verkar inte förlorat någon gas heller. Fick inte i ett dugg när jag provade tanka idag.

Iroc
Inlägg: 111
Blev medlem: 2010-12-13, 20:15
Ort: Lidköping

Re: V70 -10 AFV Startar ej på gas

Inlägg av Iroc » 2015-05-19, 16:54

Hej.
Har samma problem som dig. Nyss köpt en gammal taxi från 2011 där gasdriften inte funkar.
Ska snart börja forska i detta, men först måste jag få ordning på felkoder på evap och lambda, så det inte är dom som stänger av gasdriften..
Har du fortfarande felkod på motorstyrningen?? Kan vara nåt som kopplar bort gasen då.
Känn på alla slangar i motorrummet till gasdriften, mina slangar är lösa och går att vrida, vilket borde betyda att det kan läcka gas där.
Kablarna hänger överallt så ojojoj vilket kaos det är i mitt motorrum.

Styrdonen till gasdrift sitter i akvariet under torkarna.
Original ECM sitter i luftburken och kyls av inkommande luft till motorn.

Prins VSI är det som levererar gasdelarna till AFV.
http://www.prinsautogas.com/en/products ... ystem.html

All info om detta system är välkommet, elschema och manual tex..
Miljöbilsservice Lavad, verkstad främst för miljöbilar.
0704-811145

Iroc
Inlägg: 111
Blev medlem: 2010-12-13, 20:15
Ort: Lidköping

Re: V70 -10 AFV Startar ej på gas

Inlägg av Iroc » 2015-05-19, 23:36

Här kommer lite bilder. Ursäkta trådkapningen :roll:
Hittade en trasig säkring som matade evapventilen och lambdasensorer. Asgött !! Så nu ska mitt gassystem snart provas. Först måste lite kablage repareras och en tryckgivare bytas.


Bild

Katastrof !! Det verkar vara diagnoskablar som ligger ute i motorrumet. Alla kablar är märkta med liten text skrivet på varje kabel.
EDIT 2015-09-01 Dessa kablar ska kopplas parallellt över till spridare, vattentemp, bränsletryck osv, men någon har bara satt ihop alla kontakter och då funkar gasdriften inte.

Bild

Hela elsystemet till gasen var ett enda kaos. Massa kablar var torra och spruckna redan efter 4 år.
All dålig tygtejp som AFV eller Prinsgubbarna använt ska bort.. Det är en mjuk tygtejp som används mest inne i bilen för att förhindra vibrationer och skador på kablar typ. I motorrummet har den inget att göra, den suger dessutom åt sig vatten och olja.
Finns en hårdare "motorrumstejp" som borde använts.

Bild

Här på bilden ovan finns två säkringshållare som syns vid kanten av batterilådan, typ ovanför gasmätaren. Dom säkringarna går till gasstyrdonen..

Bild

Ska iväg och fixa riktiga kabelhöljen imorrn och trä över kablarna som skydd istället för den värdelösa tejpen som blir som en tvättsvamp och suger åt sig olja, salt och avfettning som gör att kablarna blir sköra och spricker med en eventuell kortslutning som följd..

Bild

Efter April 2011 blev det fyra små gastankar istället för tre stora. Lastutrymmet ökade, men det blev mindre gas i systemet istället. 98dm3 är innehållet

Bild

Tre styrdon till gasdrift sitter monterat i akvariet under torkaren.
Ett stort styrdon är i bakgrunden, sen är dessa två monterade på det större styrdonet.

Bild

Gastank..

Bild

Gasventil

Bild

Denna MAPsensor sitter monterad nära gasregulatorn. Också värdelöst monterat, slangarna ligger och vibrerar och drar i anslutningen, så denna har gått av.
Tror denna givare är speciellt till gasen ?? Eller är den till både bensin / gas system?? Hmm, ett mysterium.. zzz zzzz zzzz
Kostar 6-700:- begagnad på skroten, men på Ebay finns den för ca 210:- med frakt inräknad :mrgreen:

http://www.ebay.com/itm/MAP-Manifold-Pr ... 43d8e22df1

Oooooooooh tack Ebay för att du skänker mig dessa lyckliga stunder av shopping :lol:



Slut för idag
Senast redigerad av 1 Iroc, redigerad totalt 2015 gånger.
Miljöbilsservice Lavad, verkstad främst för miljöbilar.
0704-811145

Användarvisningsbild
olass
Inlägg: 33
Blev medlem: 2011-09-22, 17:10

Re: V70 -10 AFV Startar ej på gas

Inlägg av olass » 2015-08-27, 22:12

Iroc skrev:Här kommer lite bilder.
Ser fram emot en fortsättning på detta Iroc. Hur gick det?

Iroc
Inlägg: 111
Blev medlem: 2010-12-13, 20:15
Ort: Lidköping

Re: V70 -10 AFV Startar ej på gas

Inlägg av Iroc » 2015-09-01, 11:19

olass skrev:
Iroc skrev:Här kommer lite bilder.
Ser fram emot en fortsättning på detta Iroc. Hur gick det?

Hallå.
Jotack, det gick allt fint till slut.

Forumet har ju som dom flesta märkt legat nere under sommaren, men här kommer lite ideer för andra som ska felsöka.
Nu har jag glömt massvis, men skriver lite snabbt av det jag kommer ihåg.

1. Leta gasläckage.... Känn på alla slangar, går dom att röra och snurra på betyder det att gummit blivit hårt och slutat att täta. Ingen ide att ens försöka dra åt slangklämman. Slangen är skrot och kommer börja läcka.
Jag bytte till vanlig orange gasolslang, den är klassad för CNG också. 5mm slang ska det vara mellan spridare och insug.

2. Den svarta filterenheten som sitter efter regulatorn kostar ca 500:- , kommer inte ihåg bytesintervallen, men byt om bilen gått långt med samma filter.

3. Gå in på tex Ebay.com och sök på Prins VSI diagnostic och leta upp nåt interface med programvara. Kostar 3-400:- och sen kan man nolla och läsa felkoder. Prins VSI 1 är det fram till 2012 ( då har man den lilla fyrkantiga gastankmätaren vid växelspaken) Efter 2012 är det Prins VSI 2 och då blev gasmätaren rund. Dessa gassystem är helt fristående och man kommer inte åt det med Volvos VIDA.
Alla felkoder båda på bensin och gassystemet ska vara åtgärdade och borttagna, annars kan det vara nåt som hindrar bilen att slå över till gasdrift.

När jag kopplade in min bil och skulle läsa felkoder blev det inte ett enda värde eller insignal som stämde. Ingen varvsignal, vattentemp, spridare... Inget gick att se.
Då tändes lilla lampan över huvudet, pling :idea: ...
Alla kablar som hängt lös, det var dom kablarna som skulle ihop med spridarna, bränsletryckregulatorn, vattentempgivare osv. Så det var bara att börja koppla och efter det så funkar det :D Nån hade ju bytt motor och slarvat väldigt med det mesta och inte vetat hur det skulle kopplas så dom hade bara satt ihop alla kontakter.


Det tråkiga med min bil nu är att den började bygga tryck i kylsystemet så nu är topplocket avmonterat. Passar då på att göra den saftigt dyra ventiljusteringen som ska göras efter 9000 mil.
Mina ventillyftare var väldigt slitna, fast det inte var nåt direkt ventiltickande.
Så nu är det dags att gå ut och kapa sönder en gammal ventilkåpa och göra en hållare för kamaxlarna så man kan mäta ventilspelet utan att behöva skaffa volvos specialverktyg.

Åååh, bara massa jobb jobb jobb med gamla bilar :lol: Men man lär sig väldigt mycket
Miljöbilsservice Lavad, verkstad främst för miljöbilar.
0704-811145

kklasen
Inlägg: 4
Blev medlem: 2015-04-06, 23:40
Ort: Norrköping

Re: V70 -10 AFV Startar ej på gas

Inlägg av kklasen » 2015-09-04, 21:18

WoW vilken röra! Skit att du ens fick ordning på det, helt otroligt.

Jag hade inne min på Rejmes för ett tag sedan.
De provade byta tryckregulator framme i motorutrymmet och någon givare där intill, så nu funkar det igen.
Kostnad: 3200kr inkl verkstadstid, helt okej.

De passade på att installera ny mjukvara i gas-systemet. Det var gratis.
Mjukvaran fick Rejmes tag på direkt via Westport som nu äger AFV.

Har försökt posta detta tidigare, men forumet var som sagt nere.
Om ägare läser och vill ha hjälp med hosting, så har jag tillgångar för att kunna hjälpa till med det.

seppok
Inlägg: 2
Blev medlem: 2017-01-24, 12:13

Re: V70 -10 AFV Startar ej på gas

Inlägg av seppok » 2017-01-24, 12:19

Iroc skrev:
olass skrev:
Iroc skrev:Här kommer lite bilder.
3. Gå in på tex Ebay.com och sök på Prins VSI diagnostic och leta upp nåt interface med programvara. Kostar 3-400:- och sen kan man nolla och läsa felkoder. Prins VSI 1 är det fram till 2012 ( då har man den lilla fyrkantiga gastankmätaren vid växelspaken) Efter 2012 är det Prins VSI 2 och då blev gasmätaren rund. Dessa gassystem är helt fristående och man kommer inte åt det med Volvos VIDA.
Alla felkoder båda på bensin och gassystemet ska vara åtgärdade och borttagna, annars kan det vara nåt som hindrar bilen att slå över till gasdrift.
Tack för informationen! Jag har samma problem och beställde kabeln, men var är diagnosuttaget?

Iroc
Inlägg: 111
Blev medlem: 2010-12-13, 20:15
Ort: Lidköping

Re: V70 -10 AFV Startar ej på gas

Inlägg av Iroc » 2017-01-24, 23:04

seppok skrev:
Iroc skrev:
olass skrev:
Tack för informationen! Jag har samma problem och beställde kabeln, men var är diagnosuttaget?

Kika runt lite vid batteriet. Där nånstans ligger det två fyrpoliga kontakter.. Du ser dom på bilderna högre upp. En grå och en svart.
Miljöbilsservice Lavad, verkstad främst för miljöbilar.
0704-811145

seppok
Inlägg: 2
Blev medlem: 2017-01-24, 12:13

Re: V70 -10 AFV Startar ej på gas

Inlägg av seppok » 2017-02-07, 21:37

Iroc skrev:Kika runt lite vid batteriet. Där nånstans ligger det två fyrpoliga kontakter.. Du ser dom på bilderna högre upp. En grå och en svart.
Tack! Allting verkar vara bra, men RPM finns inte. Vet du var är anslutningen till RPM-sensorn?

edit: Jag hittade den. Allt är ok med kablarna, men RPM signal finns inte i diagnosprogrammet. Nu tror jag att felet är i VSI eller Prins Timing Optimizer (PTO). Ideer?

Iroc
Inlägg: 111
Blev medlem: 2010-12-13, 20:15
Ort: Lidköping

Re: V70 -10 AFV Startar ej på gas

Inlägg av Iroc » 2017-02-25, 12:43

seppok skrev:
Iroc skrev:Kika runt lite vid batteriet. Där nånstans ligger det två fyrpoliga kontakter.. Du ser dom på bilderna högre upp. En grå och en svart.
Tack! Allting verkar vara bra, men RPM finns inte. Vet du var är anslutningen till RPM-sensorn?

edit: Jag hittade den. Allt är ok med kablarna, men RPM signal finns inte i diagnosprogrammet. Nu tror jag att felet är i VSI eller Prins Timing Optimizer (PTO). Ideer?

Kolla efter spruckna torra kablar..Följ kablaget till kontakthuset, där sitter det en skarv för att plocka ut RPM signal till CNG systemet
Miljöbilsservice Lavad, verkstad främst för miljöbilar.
0704-811145

domarniklas
Inlägg: 7
Blev medlem: 2014-08-11, 10:56

Re: V70 -10 AFV Startar ej på gas

Inlägg av domarniklas » 2017-07-01, 18:28

Hej.
Hoppas jag inte bryter mot några forumregler nu, är inte van vid detta.

Jo, jag har typ samma problem som tidigare skribenter.
Bor i Umå där det inte finns tillgång till gasmack. Har en v70 2010 afv.
Brukar tanka gas en till 2 ggr per år när vi åker söderut i landet. Måste ju ha gas i bilen för att besikta. Det brukar alltid funka klockrent. Men nu när jag tankade gas Dörr veckan hände ingenting. Den vägrar gå över på gasen. Oavsett om jag trycker på den lilla fyrkantiga gastankmätaren.
Det brukar bara ta max en minut innan den går över på gas.
Manometern i motorrummet visar 0.
Har öppnat och kollat säkringar och alla kablar jag kan se både under motorhuven och bak vid tankarna.

Ett problem jag har är att jag har typ den enda gasbilen i stan så det finns inga verkstäder som är haj på detta.
Vill inte heller lämna in den och nån ska gissa vad som kanske måste bytas och betala för saker som troligen ät hela.
Fråga 1: ska mätaren under huven visa tryck jämt om det finns gas i tanken, eller är det bara om bilen går på gas?

Fråga 2: i vilken ordning, och VAD tycker ni att jag ska felsöka?

Det jag har gjort som är utöver det vanliga sedan förra gången gasen fungerade är att jag har gjort bilen helt strömlös för att nollställa klimatanläggning/radio som hängt sig. (funkade igen efter strömlöshet)

Så tacksam för svar i detta ärende då jag snart måste besiktiga bilen och då behöver det ju fungera. Tack på förhand
/Niklas

domarniklas
Inlägg: 7
Blev medlem: 2014-08-11, 10:56

Re: V70 -10 AFV Startar ej på gas

Inlägg av domarniklas » 2017-08-10, 20:06

Puffar.....

Har köpt diagnosverktyg och hade 2 felkoder som inte verkar ha med gasen att göra. Nollade dem men det fungerar ännu inte.
Kan någon hjälpa mig hur jag felsöker i vsi-programmet?

dawen
Inlägg: 18
Blev medlem: 2016-01-13, 18:27

Re: V70 -10 AFV Startar ej på gas

Inlägg av dawen » 2018-07-22, 09:49

Hur har det gått för dig Niklas?

domarniklas
Inlägg: 7
Blev medlem: 2014-08-11, 10:56

Re: V70 -10 AFV Startar ej på gas

Inlägg av domarniklas » 2018-07-22, 09:59

Jo bra, och dåligt.
Fick hjälp att byta mjukvara (en klump i torkardiket.
Sen funkade det. Men efter det har jag inte tankat gas på nästan ett år och nu när jag tankade gas så funkar det dåligt. Bilen går bara några sekunder på gas och går ryckigt innan den stänger gasen och börjar pipa.
Detta hände för 2 dagar sedan.

Skriv svar